Banking on your terms

The Internet- and mobile banks are always open and allows you to do most of your errends at times that suit you. And you don't have to spend time waiting i line in a store. 

In the Mobile bank, you can also send secure messages to customer service. The app is available for iPhone and Android. Download the latest version to your smatphone, wither by visiting this page in your smartphone browser and click the buttons below, or by searching for FOREX mobilbank where you download apps.

  • See balance and transactions
  • Make payments
  • Manage e-invoices and automatic payments
  • Cancel a lost card

Ladda ner mobilbanken på iPhone

Om du har en iPhone så laddar du ner vår bankapp på App Store. Klicka nedan för att komma till App Store och ladda ner mobilbanken.

Ladda ner mobilbanken på Android

Om du har en Android Smartphone så hittar du vår bankapp på Google Play. Klicka nedan för att komma till Google Play och ladda ner Mobilbanken.

Prices, terms and payment guide

Prices

Internet bank Included in Private and savings account and in Loans.
Mobile Bank  Included in Private and savings account and in Loans.

Currency app

See rates and buy currencty in your smartphone.

Read more

Mobile BankID

Your electronic ID for online purchases, signing agreements and more.

Read more

Swish

Make payments and send money, using only recipients phone number.

Read more

System requirements

in order for the services to operate at an optimal level, you need to have a version of your operating system that is supported by us. If you have an older version and experience disturbances, please update and try again.

Internet bank

Your computer must allow javascript. Supprted broswers and operating systems: 

  • Windows 2000, Vista eorWindows 7
  • Google Chrome, we recommend the latest version
  • Internet Explorer, version 8.0 or later
  • Microsoft Edge
  • Safari, version 5.0 or later
  • Mozilla Firefox, version 9.0 or later
  • Opera, version 10.0 or later

Mobile bank

  • Android with Android 4.1 or later
  • iPhone with iOS 9.0 or later